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Copyright

This document is licensed under the Creative Commons Attribution-No Deriva-
tive Works 3.0 License. To view a copy of this license, visit http://creativecommons.
org/licenses/by-nd/3.0/.

1 Introduction

ElmerGUI is a graphical user interface for the Elmer software suite [1]. The
program is capable of importing finite element mesh files in various formats,
generating finite element partitionings for various geometry input files, set-
ting up PDE-systems to solve, and exporting model data and results for
ElmerSolver and ElmerPost to visualize. ElmerGUI has also an internal
postprocessor, which can be used as an alternative to ElmerPost, to draw
color surfaces, contours, vector fields, and visualize time dependent data.

Figure 1: Main window of ElmerGUI.

One of the main features of ElmerGUI is the interface to the parallel
solver, ElmerSolver mpi. The GUI hides from the user a number of opera-
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tions that are normally performed from command line with various external
tools related to domain decomposition, launching the parallel processes, and
merging the results. This makes it possible to use ElmerSolver with multi-
core processors, even on interactive desktop environments.

The menus of ElmerGUI are programmable and it should be relatively
easy to strip and customize the interface for proprietary applications. An
example of customizing the menus is provided in appendix A.

ElmerGUI relies on the Qt4 cross platform framework of QtSoftware [6],
and it uses the Qwt5 libray by Josef Wilgen and Uwe Rathman[7] to plot
scientific data. The internal postprocessor of ElmerGUI is based on the Vi-
sualization Toolkit (VTK) of Ken Martin, Will Schroeder, and Bill Lorensen
[10]. The CAD import features are implemented by the OpenCASCADE
(OCC) library from OpenCASCADE S.A.S. [5]. The program is also capa-
ble of using Tetgen [8] and Netgen [4] as finite element mesh generators.

2 Installation from source

The source code of ElmerGUI is available from the subversion repository
of SourceForge.Net. The GPL licenced source code may be downloaded by
executing the following command with a SVN client program(on Windows
the Tortoise SVN client is recommended):

svn co https://elmerfem.svn.sourceforge.net/svnroot/elmerfem/trunk trunk

This will retrieve the current development version of the whole Elmer-suite.

2.1 Linux

Bofore starting to compile, please make sure that you have the development
package of Qt 4 installed on your system (i.e., libraries, headers, and program
development tools). Qt version 4.3 or newer is recommended. You may also
wish to install Qwt 5, VTK version 5 (compiled with support to Qt4), and
OpenCASCADE 6.3, for additional functionality.

The program is compiled and installed by executing the following se-
quence of commands in a terminal window:

$ cd elmerfem/trunk/ElmerGUI

$ qmake

$ make

$ make install
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The default installation directory defined in the project file ElmerGUI.pri is
/usr/local/bin.

It is possible that the project definition file “ElmerGUI.pri” needs to be
edited and modified, depending on how and where the external libraries have
been installed. The lines that need attention can be found from the beginning
of the file.

Once the build process has finished, it suffices to set up the environment
variable ELMERGUI HOME and add it to PATH:

$ export ELMERGUI_HOME=/usr/local/bin

$ export PATH=$PATH:$ELMERGUI_HOME

The program is launhed by the command

$ ElmerGUI

Later, it is possible to update ElmerGUI by the following commands
within the build directory:

$ svn update

$ make

$ make install

2.2 Windows

On 32-bit Windows systems, it is possible to use precompiled binary pack-
ages, which are distributed through the file release system of SourceForge.NET
[2]. The binary packages may depend on external components, which must
be installed prior to downloading Elmer. The list of possible dependencies
can be found from the “Release notes” of the package.

It is also possible to compile ElmerGUI from source. This can be done
either by Visual Studio 2008 C++ Express Edition [9] (or any other MS
compiler that provides at least the same functionality), or by using the GNU
Compiler Collection provided by the MinGW project [3].

The compilation instructions for MinGW are more or less the same as for
Linux. The only exception is that then OCC should probably be excluded
from compilation.

The advantage of using MinGW is that it is then possible to use Qt’s pre-
compiled binary packages [6], which otherwise have to be built from source.
MinGW might also be the natural choice for users that prefer Unix-like op-
erating environments.

The easiest way to compile ElmerGUI with VC++ is to invoke “Visual
Studio 2008 Command Prompt” and execute the following sequence com-
mands within ElmerGUI’s source directory:
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> qmake

> nmake

> nmake install

Again, it is necessary to verify that the search paths to all external com-
ponents have been correctly defined in “ElmerGUI.pri”. The build process is
performed in release mode, producing the executable “Application/release/ElmerGUI.exe”.

The final task is to introduce the environment variable ELMERGUI HOME

with value c:/Elmer5.4/bin and add it to the binary search path (right-click
My Computer → Properties → Advanced → Environment variables)

3 Input files

3.1 Geometry input files and mesh generation

ElmerGUI is capable of importing finite element mesh files and generating
two or three dimensional finite element partitionings for bounded domains
with piecewise linear boundaries. It is possible to use one of the following
mesh generators:

• ElmerGrid (built-in)

• Tetgen (optional)

• Netgen (built-in)

The default import filter and mesh generator is ElmerGrid. Tetgen is an
optional module, which may or may not be available depending on the instal-
lation (installation and compilation instructions can be found from Elmer’s
source tree in trunk/misc)

An import filter or a mesh generator is selected automatically by Elmer-
GUI when a geometry input file is opened:

File → Open...

The selection is based on the input file suffix according to Table 1. If
two or more generators are capable of handing the same format, then the
user defined “preferred generator” will be used. The preferred generator is
defined in

Mesh → Configure...

Once the input file has been opened, it is possible to modify the mesh
parameters and remesh the geometry for better accuracy or computational
efficiency. The mesh parameters can be found from Mesh → Configure....
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The control string for Tetgen has been discussed and explained in detail in
Tetgen’s user guide [8].

Suffix ElmerGrid Tetgen Netgen
.FDNEUT yes no no

.grd yes no no
.msh yes no no

.mphtxt yes no no
.off no yes no
.ply no yes no
.poly no yes no

.smesh no yes no
.stl no yes yes
.unv no yes no
.in2d no no yes

Table 1. Input files and capabilities of the mesh generators.

The mesh generator is reactivated from the Mesh menu by choosing

Mesh → Remesh

In case of problems, the meshing thread may be terminated by executing

Mesh → Terminate meshing

3.2 Elmer mesh files

An Elmer mesh consists of the following four text files (detailed description
of the file format can be found from Appendix B):

mesh.header
mesh.nodes
mesh.elements
mesh.boundary

Elmer mesh files may be loaded and/or saved by opening the mesh direc-
tory from the File menu:

File → Load mesh...

and/or

File → Save as...
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3.3 Project files

An ElmerGUI project consists of a project directory containing Elmer mesh
files and an xml-formatted document egproject.xml describing the current
state and settings. Projects may be loaded and/or saved from the File menu
by choosing

File → Load project...

and/or

File → Save project...

When an ElmerGUI project is loaded, a new solver input file will be
generated and saved in the project directory using the sif-name defined in

Model → Setup...

If there is an old solver input file with the same name, it will be overwritten.
The contents of a typical project directory is the following:

case.sif
egproject.xml
ELMERSOLVER_STARTINFO
mesh.boundary
mesh.elements
mesh.header
mesh.nodes

4 Model definitions

4.1 Setup menu

The general setup menu can be found from

Model → Setup...

This menu defines the basic variables for the “Header”, “Simulation”, and
“Constants” blocks for a solver input file. The contents of these blocks have
been discussed in detail in the SolverManual of Elmer [1].

4.2 Equation menu

The first “dynamical menu” constructed from the ElmerGUI definition files
(see Appendix A) is

Model → Equation
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Figure 2: Setup menu.

This menu defines the PDE-system to be solved as well as the numerical
methods and parameters used in the solution. It will be used to generate the
“Solver” blocks in a solver input file.

A PDE-system (a.k.a “Equation”) is defined by choosing

Model → Equation → Add...

Once the PDE-system has been defined by activating the individual equa-
tions, the numerical methods and parameters can be selected and tuned by
pressing the “Edit Solver Settings” button. The name the PDE-system is
defined in the line edit box with label “Name”. After pressing the Ok-button,
the equation remains visible and editable under the Model menu.

It is also possible to attach an equation to a body by holding down the
SHIFT-key while double clicking one of its surfaces. A pop up menu will then
appear, listing all possible attributes that can be attached to the selection.
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Figure 3: Equation menu.

4.3 Material menu

The next menu is related to material and model parameters:

Model → Material

This menu will be used to generate the “Material” blocks in a solver input
file.

In order to define a material parameter set and attach it to bodies, choose

Model → Material → Add...

Again, it is possible to attach the material to a body by holding down
the SHIFT-key while double clicking one of its boundaries.

Note: The value of density should always be defined in the “General”
tab. This field should never be left undefined.

Note: If you set focus in a line edit box of a dynamical menu and press
Enter, a small text edit dialog will pop up. This allows the input of more
complicated expressions than just constants. As an example, go to Model →
Material and choose Add... Place the cursor in the “Heat conductivity” line
edit box of “Heat equation” and press Enter. You can then define the heat
conductivity as a function of temperature as a piecewise linear function. An

11



Figure 4: Solver settings menu.

example is show in Figure N. In this case, the heat conductivity gets value
10 if the temperature is less than 273 degrees. It then rises from 10 to 20
between 273 and 373 degrees, and remains constant 20 above 373 degrees.

If the user presses SHIFT and F1, a tooltip for the active widget will be
displayed.

4.4 Body force menu

The next menu in the list is

Model → Body force

This menu is used to construct the “Body force” blocks in a solver input file.
Again, choose

Model → Body force → Add...

to define a set of body forces and attach it to the bodies.

4.5 Initial condition menu

The last menu related to body properties is
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Figure 5: Body property editor is activated by holding down the SHIFT key
while double clicking a surface.

Model → Initial condition

Once again, choose

Model → Initial condition → Add...

to define a set of initial conditions and attach it to the bodies.
This menu is used to construct the “Initial condition” blocks in a solver

input file.

4.6 Boundary condition menu

Finally, there is a menu entry for setting up the boundary conditions:

Model → Boundary condition

Choose

Model → Boundary condition → Add...

to define a set of boundary conditions and attach them to boundaries.
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Figure 6: Material menu.

It is possible to attach a boundary condition to a boundary by holding
down the ALT or ALTGR-key while double clicking a surface or edge. A pop
up menu will appear, listing all possible conditions that can be attached to
the selection. Choose a condition from the combo box and finally press Ok.

5 Utility functions

5.1 Boundary division and unification

Some of the input file formats listed in Table 1 are not perhaps so well suited
for FE-calculations, eventhough widely used. The .stl format (stereo litog-
raphy format), for example, is by definition unable to distinguish between
different boundary parts with different attributes. Moreover, the format ap-
proximates the boundary by disconnected triangles that do not fulfill the
usual FE-compatibility conditions.

In order to deal with formats like .stl, ElmerGUI provides a minimal
set of tools for boundary division and unification. The division is based on
“sharp edge detection”. An edge between two boundary elements is con-
sidered sharp, if the angle between the normals exceeds a certain value (20
degrees by default). The sharp edges are then used as a mortar to divide
the surface into parts. The user may perform a sharp edge detection and
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Figure 7: Tooltips are shown by holding down the SHIFT and F1 keys.

boundary division from the Mesh menu by choosing

Mesh → Divide surface...

In 2D the corresponding operation is

Mesh → Divide edge...

The resulting parts are enumerated starting from the first free index.
Sometimes, the above process produces far too many distinct parts, which

eventually need to be (re)unified. This can be done by selecting a group of
surfaces by holding down the CTRL-key while double clicking the surfaces
and choosing

Mesh → Unify surface...

The same operation in 2D is

Mesh → Unify edge...

The result will inherit the smallest index from the selected group.
The sharp edges that do not belong to a closed loop may be removed by

Mesh → Clean up
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Figure 8: Text edit extension of a line edit box is activated by pressing Enter.

This operation has no effect on the boundary division, but sometimes it
makes the result look better.

5.2 Saving pictures

The model drawn on the display area may be scanned into a 24-bit RGB
image and saved in several picture file formats:

File → Save picture as...

The function supports .bmp, .jpg, .png, .pbm, .pgm, and .ppm file extensions.

5.3 View menu

The View menu provides several utility functions for controlling the visual
behaviour of ElmerGUI. The function names should be more or less self
explanatory.
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Figure 9: Body force menu.

6 Solver input files

The contents of the Model menu are passed to the solver in the form of a
solver input file. A solver input file is generated by choosing

Sif → Generate

The contents of the file are editable:

Sif → Edit...

The new sif file needs to saved before it becomes active. The recom-
mended method is

File → Save project...

In this way, also the current mesh and project files get saved in the same
directory, avoiding possible inconsistencies later on.

7 Solution and post processing

7.1 Running the solver

Once the solver input file has been generated and the project has been saved,
it is possible to actualy solve the problem:
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Figure 10: Initial condition menu.

Run → Start solver

This will launch either a single process for ElmerSolver (scalar solution) or
multiple MPI-processes for ElmerSolver mpi (parallel solution) depending on
the definitions in

Run → Parallel settings...

The parallel menu has three group boxes. Usually, the user is supposed to
touch only the “General settings” group and select the number of processes to
execute. The two remaining groups deal with system commands to launch
MPI-processes and external tools for domain decomposition. The parallel
menu is greyed out if ElmerSolver mpi is not present at start-up.

When the solver is running, there is a log window and a convergence
monitor from which the iteration may be followed. In case of divergence or
other troubles, the solver may be terminated by choosing

Run → Kill solver

The solver will finally write a result file for ElmerPost in the project
directory. The name of the ep-file is defined in

Model → Setup...
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Figure 11: Boundary condition menu.

7.2 Post preocessing I (ElmerPost)

ElmerGUI provides two different post processors for drawing, displaying, and
manipulating the results.

The first alternative is activated from

Run → Start postprocessor

This will launch ElmerPost, which will read in the result file and displays a
contour plot representing the solution. If the results were prodoced by the
parallel solver, the domain decomposition used in the calculations will be
shown.

7.3 Post preocessing II (VTK)

The second post processor is based on the Visualization Toolkit, VTK. It is
activated from

Run → Postprocessor (VTK)...

A new window will then pop up, providing methods for drawing surfaces,
contours, vectors, and stream lines.
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Figure 12: Boundary property editor activated by holding down the ALTGR
key while double clicking a surface.

7.3.1 Python interface

If ElmerGUI has been compiled with PyhthonQt-support, there is a Python
console available for scripting. The console is located under the Edit-menu:

Edit → PythonQt console...

The console provides access to the following classes:

egp // ElmerGUI post processor
matc // MATC language interpreter
preferences // controls for preferences
surfaces // controls for surface plots
vectors // controls for vector fields
isoContours // controls for isocontours
isoSurfaces // controls for isosurfaces
streamLines // controls for streamlines
colorBar // cotrols for the colorbar
timeStep // controls for transient results
text // text annotation

Each of the above classes provides a number of useful methods for data
and display manipulation. To fix ideas, suppose that we want to read in
the result file “case.ep” and display the temperature fields as a semi trans-
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Figure 13: Parallel settings dialog.

parent surface plot. The commands to execute are then the following (more
examples can be found in section 7.3.3):

py> egp.ReadPostFile("case.ep")
py> egp.SetSurfaces(True)
py> surfaces.SetFieldName("Temperature")
py> surfaces.SetOpacity(50)
py> egp.Redraw()

7.3.2 Public methods

Interface version 0.2:

class egp:
bool MatcCmd(QString); // evaluate MATC cmd
void domatcSlot(); // flush MATC console

void SetPostFileStart(int); // first time step
void SetPostFileEnd(int); // last time step
bool ReadPostFile(QString); // read result file

void Render(); // render
void ResetCamera(); // reset camera
void Redraw(); // redraw actors
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void ResetAll(); // reset view

void SetSurfaces(bool); // show/hide surfaces
void SetVectors(bool); // show/hide vectors
void SetIsoContours(bool); // show/hide isocontours
void SetIsoSurfaces(bool); // show/hide isosurfaces
void SetStreamLines(bool); // show/hide streamlines
void SetColorBar(bool); // show/hide colorbar
void SetMeshPoints(bool); // show/hide/nodes
void SetMeshEdges(bool); // show/hide edges
void SetFeatureEdges(bool); // show/hide f-edges
void SetAxes(bool); // show/hide axes
void SetText(bool); // show/hide text

bool GetClipAll(); // is clipping on?
void SetClipAll(bool); // clipping on/off
void SetClipPlaneOx(double); // clip plane origin
void SetClipPlaneOy(double); // clip plane origin
void SetClipPlaneOz(double); // clip plane origin
void SetClipPlaneNx(double); // clip plane normal
void SetClipPlaneNy(double); // clip plane normal
void SetClipPlaneNz(double); // clip plane normal

double GetCameraDistance(); // get camera distance
void SetCameraDistance(double); // set camera distance
double GetCameraPositionX(); // get camera position
double GetCameraPositionY(); // get camera position
double GetCameraPositionZ(); // get camera position
void SetCameraPositionX(double); // set camera position
void SetCameraPositionY(double); // set camera position
void SetCameraPositionZ(double); // set camera position
double GetCameraFocalPointX(); // get focal point
double GetCameraFocalPointY(); // get focal point
double GetCameraFocalPointZ(); // get focal point
void SetCameraFocalPointX(double); // set focal point
void SetCameraFocalPointY(double); // set focal point
void SetCameraFocalPointZ(double); // set focal point
void CameraDolly(double); // dolly
void CameraRoll(double); // roll
void CameraAzimuth(double); // azimuth
void CameraYaw(double); // yaw
void CameraElevation(double); // elevation
void CameraPitch(double); // pitch
void CameraZoom(double); // zoom
void SetCameraRoll(double); // set roll
void SetInitialCameraPosition(); // set initial position

void RotateX(double); // rotate visible actors
void RotateY(double); // rotate visible actors
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void RotateZ(double); // rotate visible actors
void SetOrientation(double, double, double); // set orientation
void SetPositionX(double); // set position
void SetPositionY(double); // set position
void SetPositionZ(double); // set position
void SetPosition(double, double, double); // set position
void AddPosition(double, double, double); // add position
void SetOrigin(double, double, double); // set origin
void SetScaleX(double); // set scale
void SetScaleY(double); // set scale
void SetScaleZ(double); // set scale
void SetScale(double, double, double); // set scale
double GetLength(); // get model size
double GetNofNodes(); // get nof nodes
double GetMinX(); // bounding box
double GetMaxX(); // bounding box
double GetMinY(); // bounding box
double GetMaxY(); // bounding box
double GetMinZ(); // bounding box
double GetMaxZ(); // bounding box

bool SavePngFile(QString); // save image file

void SetBgColor(double, double, double); // bg color (RGB: 0..1)

class matc:
bool SetCommand(QString); // Enter MATC cmd

class preferences:
void UseSurfaceMeshForPoints(bool); // nodes of surface mesh
void UseVolumeMeshForPoints(bool); // nodes of volume mesh
void SetPointSize(int); // set node point size
void SetPointQuality(int); // set node point quality
void UseClipPlaneForPoints(bool); // clip nodes
void UseSurfaceMeshForEdges(bool); // edges of surface mesh
void UseVolumeMeshForEdges(bool); // edges of volume mesh
void UseTubeFilterForEdges(bool); // use tube filter
void UseClipPlaneForEdges(bool); // clip edges
void SetLineWidthForEdges(int); // edge line width
void SetTubeQualityForEdges(int); // edge tube quality
void SetTubeRadiusForEdges(int); // edge tube radius
void UseSurfaceMeshForFeatureEdges(bool); // surface mesh: f-edges
void UseVolumeMeshForFeatureEdges(bool); // volume mesh: f-edges
void UseTubeFilterForFeatureEdges(bool); // use tube filter
void UseClipPlaneForFeatureEdges(bool); // clip f-edges
void DrawBoundaryEdges(bool); // draw boundary edges
int GetFeatureAngle(); // get feature angle
void SetFeatureAngle(int); // set feature angle
void SetLineWidthForFeatureEdges(int); // f-edge line width
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void SetTubeQualityForFeatureEdges(int); // f-edge tube quality
void SetTubeRadiusForFeatureEdges(int); // f-edge tube radius
void SetClipPlaneOx(double); // clip plane origin
void SetClipPlaneOy(double); // clip plane origin
void SetClipPlaneOz(double); // clip plane origin
void SetClipPlaneNx(double); // clip plane normal
void SetClipPlaneNy(double); // clip plane normal
void SetClipPlaneNz(double); // clip plane normal

class surfaces:
QString GetFieldName(); // get field name
bool SetFieldName(QString); // set field name
void SetMinVal(double); // set minimum
void SetMaxVal(double); // set maximum
void KeepLimits(bool); // keep limits
void SetComputeNormals(bool); // shade model
void SetFeatureAngle(int); // feature angle
void SetOpacity(int); // set opacity
void SetClipPlane(bool); // set clipping

class vectors:
QString GetFieldName(); // get field name
bool SetFieldName(QString); // set field name
void SetMinVal(double); // set minimum
void SetMaxVal(double); // set maximum
void KeepLimits(bool); // keep limits
void SetComputeNormals(bool); // shade model
void SetFeatureAngle(int); // feature angle
void SetOpacity(int); // set opacity
void SetClipPlane(bool); // set clipping

class isoContours:
QString GetFieldName(); // get field name
QString GetColorName(); // get color name
bool SetFieldName(QString); // set field name
bool SetColorName(QString); // set color name
void SetMinFieldVal(double); // set min value
void SetMaxFieldVal(double); // set max value
void SetContours(int); // set nof contours
void KeepFieldLimits(bool); // keep limits
void SetMinColorVal(double); // set color min
void SetMaxColorVal(double); // set color max
void KeepColorLimits(bool); // keep color limits
void UseTubeFilter(bool); // use tube filter
void UseClipPlane(bool); // set clipping on/off
void SetLineWidth(int); // set line width
void SetTubeQuality(int); // set tube quality
void SetTubeRadius(int); // set tube radius
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class isoSurfaces:
QString GetFieldName(); // get field name
QString GetColorName(); // get color name
bool SetFieldName(QString); // set field name
bool SetColorName(QString); // set color name
void SetMinFieldVal(double); // set min value
void SetMaxFieldVal(double); // set max value
void SetContours(int); // nof contours
void KeepFieldLimits(bool); // keep limits
void SetMinColorVal(double); // set color min
void SetMaxColorVal(double); // set color max
void KeepColorLimits(bool); // keep color limits
void ComputeNormals(bool); // shade model
void UseClipPlane(bool); // set clpping on/off
void SetFeatureAngle(int); // set feature angle
void SetOpacity(int); // set opacity

class streamLines:
QString GetFieldName(); // get field name
QString GetColorName(); // get color name
bool SetFieldName(QString); // set field name
bool SetColorName(QString); // set color name
void SetMaxTime(double); // max time
void SetStepLength(double); // step length
void SetThreads(int); // nof threads
void SetIntegStepLength(double); // integ. step length
void UseSurfaceMesh(bool); // use forface mesh
void UseVolumeMesh(bool); // use volume mesh
void IntegrateForwards(bool); // integrate forwards
void IntegrateBackwards(bool); // integrate backwards
void SetMinColorVal(double); // color min val
void SetMaxColorVal(double); // color max value
void KeepColorLimits(bool); // keep color limits
void DrawLines(bool); // draw using lines
void DrawRibbons(bool); // draw using ribbons
void SetLineWidth(int); // line width
void SetRibbonWidth(int); // ribbon width
void UseSphereSource(bool); // use sphere source
void UseLineSource(bool); // use line source
void UsePointSource(bool); // use point source
void SetSphereSourceX(double); // sphere origin
void SetSphereSourceY(double); // sphere origin
void SetSphereSourceZ(double); // sphere origin
void SetSphereSourceRadius(double); // sphere radius
void SetSphereSourcePoints(int); // nof pts in sphere
void SetLineSourceStartX(double); // line start point
void SetLineSourceStartY(double); // line start point
void SetLineSourceStartZ(double); // line start point
void SetLineSourceEndX(double); // line end point
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void SetLineSourceEndY(double); // line end point
void SetLineSourceEndZ(double); // line end point
void SetLineSourcePoints(int); // nof pts on line

class colorBar:
bool SetFieldName(QString); // set field name
void UseHorizontalLayout(bool); // horizontal layout
void UseVerticalLayout(bool); // vertical layout
void AnnotateFieldName(bool); // annotate field name
void SetLabels(int); // set nof labels
void SetLineWidth(double); // set line width
void SetLength(double); // set bar length

class timeStep:
void SetCurrent(int); // set current step
void SetStart(int); // set first step
void SetStop(int); // set last step
void SetIncrement(int); // set increment
void SetMatcCmd(QString); // set MATC cmd
void RegenerateBeforeDrawing(bool); // regenerate actors
void SaveFrames(bool); // save frames
void SetSaveDirectory(QString); // set save dir
void Loop(); // toggle looping
bool IsLooping(); // is loop on?
void DrawCurrent(); // draw current frame

class text:
void SetMessage(QString); // annotation
void SetPosX(int); // set x-position
void SetPosy(int); // set y-position
void SetLeft(); // justification
void SetCentered(); // justification
void SetRight(); // justification
void SetSize(int); // font size
void SetBold(bool); // bold
void SetItalic(bool); // italic
void SetShadow(bool); // shadow
void SetRed(double); // red (0..1)
void SetGreen(double); // green (0..1)
void SetBlue(double); // blue (0..1)
void SetRGB(double, double, double); // text color (RGB: 0..1)

7.3.3 Example scripts

The exampels below are executed from the PythonQt-console as

py> execfile("sample.py")

where “sample.py” is a text file containing the script to run.
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Read in results

egp.ReadPostFile("case.ep")

Set orientation

egp.ReadPostFile("case.ep")
egp.SetSurfaces(True)
egp.SetOrientation(45, 45, 0)
egp.SetInitalCameraPosition()

Visualize temperature on surfaces

egp.ReadPostFile("case.ep")
egp.SetSurfaces(True)
egp.SetOrientation(45, 45, 0)
egp.SetInitalCameraPosition()
surfaces.SetFieldName("Temperature")
egp.Redraw()

Rotate object

import time
egp.ReadPostFile("case.ep")
egp.SetSurfaces(True)
for i in range (180):

egp.RotateY(2.0)
egp.ResetCamera()
egp.Render()
time.sleep(0.1)

Traveling isosurface

The following script makes an iso surface (z = const.) travel through the
model in 100 steps. The surface is colored according to the temperature
field. The model it self is drawn transparent.

import time
egp.ReadPostFile("case.ep")
egp.SetSurfaces(True)
egp.SetIsoSurfaces(True)
egp.SetFeatureEdges(True)
preferences.SetFeatureAngle(45)
surfaces.SetFieldName("Null")
surfaces.SetOpacity(20)
isoSurfaces.SetFieldName("nodes_z")
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isoSurfaces.SetColorName("Temperature")
isoSurfaces.SetContours(1)
isoSurfaces.KeepFieldLimits(True)
egp.SetOrientation(45, 45, 0)
egp.ResetCamera()
egp.Render()
zmin = egp.GetMinZ()
zmax = egp.GetMaxZ()
for i in range(100):

z = zmin+(float(i)/100.0)*(zmax-zmin)
isoSurfaces.SetMinFieldVal(z)
isoSurfaces.SetMaxFieldVal(z)
egp.Redraw()
time.sleep(0.05)

Rotate and save frames

egp.ReadPostFile("case.ep")
egp.SetSurfaces(True)
for i in range (180):

egp.RotateY(2.0)
egp.ResetCamera()
egp.Render()
egp.SavePngFile("frame" + str(i) + ".png")

Preparing and playing back video clips

With ffmpeg (see ffmpeg’s manuals for more accurate controls):

$ ffmpeg -b 1000000 -i frame%d.png example.avi

With mencoder (see mencoder’s manuals for better controls):

$ mencoder -ovc lavc -mf type=png:fps=25 -o example.avi mf://frame%d.png

Playback with mplayer (choose appropriate frame rate):

$ mplayer -fps 50 example.avi

7.3.4 ECMAScript interface

In addition to Python, it is possible to use Qt’s internal ECMAScript engine
for scripting. The ECMAScript console is activated from the Edit menu as:

Edit → ECMAScript console...

The ECMAScript interface provides access to the same classes and meth-
ods as the Python interface. However, users familiar with e.g. JavaScript
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(from which ECMAScript has been derived and standardized) may find the
ECMAScript interface more comfortable.

ECMAScript files are executed from the console by entering the command

qs> egp.Execute("script.qs")

The above examples for Python translate to the following ECMAScript
files:

Read in results

egp.ReadPostFile("case.ep")

Set orientation

egp.ReadPostFile("case.ep")
egp.SetSurfaces(true)
egp.SetOrientation(45, 45, 0)
egp.SetInitalCameraPosition()

Visualize temperature on surfaces

egp.ReadPostFile("case.ep")
egp.SetSurfaces(true)
egp.SetOrientation(45, 45, 0)
egp.SetInitalCameraPosition()
surfaces.SetFieldName("Temperature")
egp.Redraw()

Rotate object

egp.ReadPostFile("case.ep")
egp.SetSurfaces(true)
for(var i = 0; i < 180; i++)
{

egp.RotateY(2.0)
egp.ResetCamera()
egp.Render()

}

Traveling isosurface

egp.ReadPostFile("case.ep")
egp.SetSurfaces(true)
egp.SetIsoSurfaces(true)
egp.SetFeatureEdges(true)
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preferences.SetFeatureAngle(45)
surfaces.SetFieldName("Null")
surfaces.SetOpacity(20)
isoSurfaces.SetFieldName("nodes_z")
isoSurfaces.SetColorName("Temperature")
isoSurfaces.SetContours(true)
isoSurfaces.KeepFieldLimits(true)
egp.SetOrientation(45, 45, 0)
egp.ResetCamera()
egp.Render()
var zmin = egp.GetMinZ()
var zmax = egp.GetMaxZ()
for(var i = 0; i < 100; i++)
{

var z = zmin + i/100.0 * (zmax-zmin)
isoSurfaces.SetMinFieldVal(z)
isoSurfaces.SetMaxFieldVal(z)
egp.Redraw()

}

Rotate and save frames

egp.ReadPostFile("case.ep")
egp.SetSurfaces(true)
for(var i = 0; i < 180; i++)
{

egp.RotateY(2.0)
egp.ResetCamera()
egp.Render()
egp.SavePngFile("frame" + i + ".png")

}

Visualize transient results and save frames

// Result file:
//--------------
var file = "case.ep";
var start = 1;
var end = 50;

// Read in transient results:
//----------------------------
egp.SetPostFileStart(start);
egp.SetPostFileEnd(end);
egp.ReadPostFile(file);

// Select methods:
//-----------------
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egp.SetSurfaces(true);
egp.SetFeatureEdges(true);
egp.SetText(true);

// Select scalar field:
//----------------------
surfaces.SetFieldName("Temperature");

// Loop over time steps:
//-----------------------
for(var index = start; index <= end; index++) {

timeStep.SetCurrent(index);
text.SetMessage("Time step = " + index);
egp.Redraw();
egp.SavePngFile("frame" + index + ".png");

}
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A ElmerGUI initialization file

The initialization file for ElmerGUI is located in ELMERGUI HOME/edf. It is
called egini.xml:
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<?xml version=’1.0’ encoding=’UTF-8’?>
<!DOCTYPE egini>
<egini version="1.0">

Show splash screen at startup:
<splashscreen> 1 </splashscreen>

Show system tray icon:
<systrayicon> 1 </systrayicon>

Show system tray messages:
<systraymessages> 1 </systraymessages>

System tray message duration in millisecons:
<systraymsgduration> 3000 </systraymsgduration>

Check the presence of external components:
<checkexternalcomponents> 0 </checkexternalcomponents>

Hide toolbars:
<hidetoolbars> 0 </hidetoolbars>

Plot convergence view:
<showconvergence> 1 </showconvergence>

Draw background image:
<bgimage> 1 </bgimage>

Background image file:
<bgimagefile> :/images/bgimage.png </bgimagefile>

Align background image to the bottom right corner of the screen:
<bgimagealignright> 0 </bgimagealignright>

Stretch background image to fit the display area (overrides align):
<bgimagestretch> 1 </bgimagestretch>

Maximum number of solvers / equation:
<max_solvers> 10 </max_solvers>

Maximum number of equations:
<max_equations> 10 </max_equations>

Maximum number of materials:
<max_materials> 10 </max_materials>

Maximum number of bodyforces:
<max_bodyforces> 10 </max_bodyforces>
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Maximum number of initial conditions:
<max_initialconditions> 10 </max_initialconditions>

Maximum number of bodies:
<max_bodies> 100 </max_bodies>

Maximum number of bcs:
<max_bcs> 500 </max_bcs>

Maximum number of boundaries:
<max_boundaries> 500 </max_boundaries>

</egini>

You may change the default behaviour of ElmerGUI by editing this file.
For example, to turn off the splash screen at start up, change the value of the
tag <splshscreen> from 1 to 0. To change the background image, enter a
picture file name in the <bgimagefile> tag. You might also want to increase
the default values for solvers, equations, etc., in case of very complex models.

B ElmerGUI material database

The file ELMERGUI HOME/edf/egmaterials.xml defines the material database
for ElmerGUI. The format of this file is the following:

<!DOCTYPE egmaterials>
<materiallibrary>

<material name="Air (room temperature)" >
<parameter name="Density" >1.205</parameter>
<parameter name="Heat conductivity" >0.0257</parameter>
<parameter name="Heat capacity" >1005.0</parameter>
<parameter name="Heat expansion coeff." >3.43e-3</parameter>
<parameter name="Viscosity" >1.983e-5</parameter>
<parameter name="Turbulent Prandtl number" >0.713</parameter>
<parameter name="Sound speed" >343.0</parameter>

</material>

<material name="Water (room temperature)" >
<parameter name="Density" >998.3</parameter>
<parameter name="Heat conductivity" >0.58</parameter>
<parameter name="Heat capacity" >4183.0</parameter>
<parameter name="Heat expansion coeff." >0.207e-3</parameter>
<parameter name="Viscosity" >1.002e-3</parameter>
<parameter name="Turbulent Prandtl number" >7.01</parameter>
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<parameter name="Sound speed" >1497.0</parameter>
</material>
...

</materiallibrary>

The values of the parameters may be either constant, or functions of time,
temperature, etc. A temperature dependent parameter may be defined e.g.
as

<parameter name="A" >Variable Temperature; Real; 2 3; 4 5; End</parameter>

In this case, A(2) = 3 and A(4) = 5. Values between the points are interpo-
lated linearly, and extrapolated in the tangent direction outside the domain.
The number of points defining he interpolant may be arbitrary.

C ElmerGUI definition files

The directory ELMERGUI HOME contains a subdirectory called “edf”. This is
the place where all ElmerGUI definition files (ed-files) reside. The definition
files are XML-formatted text files which define the contents and appearance
of the Model menu.

The ed-files are loaded iteratively from the edf-directory once and for all
when ElmerGUI starts. Later, it is possible to view and edit their contents
by choosing

File → Definitions...

An ed-file has the following structure:

<?xml version=’1.0’ encoding=’UTF-8’?>
<!DOCTYPE edf>
<edf version="1.0">

[PDE block]
[PDE block]
...
[PDE block]

</edf>

The structure of a [PDE block] is the following:

<PDE Name="My equation">
<Name>

My equation
</Name>
...
<Equation>
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[Widget block]
</Equation>
...
<Material>

[Widget block]
</Material>
...
<BodyForce>

[Widget block]
<BodyForce>
...
<InitialCondition>

[Widget block]
</InitialCondition>
...
<BoundaryCondition>

[Widget block]
</BoundaryCondition>

</PDE>

Note that the name of the PDE is defined redundantly in two occurances.
The basic stucture of a [Widget block] is the following:

<Parameter Widget="Label">
<Name> My label </Name>

</Parameter>
...
<Parameter Widget="Edit">

<Name> My edit box </Name>
<Type> Integer </Type>
<Whatis> Meaning of my edit box </Whatis>

</Parameter>
...
<Parameter Widget="CheckBox">

<Name> My check box </Name>
<Type> Logical </Type>
<Whatis> Meaning of my check box </Whatis>

</Parameter>
...
<Parameter Widget="Combo">

<Name> My combo box </Name>
<Type> String </Type>
<Item> <Name> My 1st item </Name> </Item>
<Item> <Name> My 2nd item </Name> </Item>
<Item> <Name> My 3rd item </Name> </Item>
<Whatis> Meaning of my combo box </Whatis>

</Parameter>

There are four types of widgets available:
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• Label (informative text)

• CheckBox (switches)

• ComboBox (selection from list)

• LineEdit (generic variables)

Each widget must be given a name and and a variable type: logical, integer,
real, or string. It is also a good practice to equip the widgets with tooltips
explaining their purpose and meaning as clearly as possible.

Below is a working example of a minimal ElmerGUI definition file. It will
add “My equation” to the equation tabs in the Model menu, see Figure N.
The file is called “sample.edf” and it should be placed in ELMERGUI HOME/edf.

<?xml version=’1.0’ encoding=’UTF-8’?>
<!DOCTYPE edf>
<edf version="1.0">
<PDE Name="My equation">
<Name> My equation </Name>
<Equation>
<Parameter Widget="Label">
<Name> My label </Name>

</Parameter>
<Parameter Widget="Edit">
<Name> My edit box </Name>
<Type> Integer </Type>
<Whatis> Meaning of my edit box </Whatis>

</Parameter>
<Parameter Widget="CheckBox">
<Name> My check box </Name>
<Type> Logical </Type>
<Whatis> Meaning of my check box </Whatis>

</Parameter>
<Parameter Widget="Combo">
<Name> My combo box </Name>
<Type> String </Type>
<Item> <Name> My 1st item </Name> </Item>
<Item> <Name> My 2nd item </Name> </Item>
<Item> <Name> My 3rd item </Name> </Item>
<Whatis> Meaning of my combo box </Whatis>

</Parameter>
</Equation>

</PDE>
</edf>

More sophisticated examples with different tags and attribites can be
found from the XML-files in ELMERGUI HOME/edf.
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Figure 14: Equation tab in Model menu produced by the sample ed-file.

D Elmer mesh files

mesh.header

nodes elements boundary-elements

types

type1 elements1

type2 elements2

...

typeN elementsN

mesh.nodes

node1 tag1 x1 y1 z1

node2 tag2 x2 y2 z2

...

nodeN tagN xN yN zN

mesh.elements
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element1 body1 type1 n11 ... n1M

element2 body2 type2 n21 ... n2M

...

elementN bodyN typeN nN1 ... nNM

mesh.boundary

element1 boundary1 parent11 parent12 n11 ... n1M

element2 boundary2 parent21 parent22 n21 ... n2M

...

elementN boundaryN parentN1 parentN2 nN1 ... nNM
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E Adding menu entries to ElmerGUI

As ElmerGUI is based on Qt4, it should be relatively easy to customize the
menus and dialog windows. A new menu item, for example, is added as
follows.

First, we declare the menu action and a private slot in src/mainwindow.h:

private slots:

...

void mySlot();

...

private:

...

QAction *myAct;

...

Then, in src/mainwindow.cpp, we actually create the action, connect an
appropriate signal from the action to the slot, and add the action in a menu:

void MainWindow::createActions()

{

...

myAct = new QAction(tr("*** My menu entry ***"), this);

connect(myAct, SIGNAL(triggered()), this, SLOT(mySlot()));

...

}

and

void MainWindow::createMenus()

{

...

meshMenu->addSeparator();

meshMenu->addAction(myAct);

...

}

It finally remains to define the slot to which the triggering signal is con-
nected. All processing related to the action should be done here:

void MainWindow::mySlot()

{

cout << "Here we go!" << endl;

}
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F ElmerGUI mesh structure

The finite element mesh generated by ElmerGUI is of class mesh t (declared
in src/meshtype.h). The mesh is private to the class GLWidget (declared in
src/glwidget.h), which is responsible of drawing and rendering the model.

F.1 GLWidget

The class GLWidget provides the following public methods for accessing the
mesh:

mesh_t* GLWidget::getMesh()

Get the active mesh.

void GLWidget::newMesh()

Allocate space for a new mesh.

void GLWidget::deleteMesh()

Delete the current mesh.

bool GLWidget::hasMesh()

Returns true if there is a mesh. Otherwise returns false.

void GLWidget::setMesh(mesh_t* myMesh)

Set active mesh to myMesh.
The mesh can be accessed in MainWindow for example as follows (see

previous section for more details):

void MainWindow::mySlot()

{

if(!glWidget->hasMesh()) return;

mesh_t* mesh = glWidget->getMesh();

cout << "Nodes: " << mesh->getNodes() << endl;

cout << "Edges: " << mesh->getEdges() << endl;

cout << "Trias: " << mesh->getSurfaces() << endl;

cout << "Tetras: " << mesh->getElements() << endl;

}
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F.2 mesh t

The class mesh t provides the following public methods for accessing and
manipulating mesh data:

bool mesh_t::isUndefined()

Returns true if the mesh is undefined. Otherwise returns false.

void mesh_t::clear()

Clears the current mesh.

bool mesh_t::load(char* dir)

Loads Elmer mesh files from directory dir. Returns false if loading failed.
Otherwise returns true.

bool mesh_t::save(char* dir)

Saves the mesh in Elmer format in directory dir. Returns false if saving
failed. Otherwise returns true.

double* mesh_t::boundingBox()

Returns bounding box for the current mesh (xmin, xmax, ymin, ymax, zmin,
zmax, xmid, ymid, zmid, size).

void mesh_t::setCdim(int cdim)

Set coordinate dimension to cdim.

int mesh_t::getCdim()

Get coordinate dimension for the current mesh.

void mesh_t::setDim(int dim)

Set mesh dimension to dim.

int mesh_t::getDim()

Get mesh dimension.

void mesh_t::setNodes(int n)

Set the number of nodes to n.

int mesh_t::getNodes()
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Get the number of nodes.

void mesh_t::setPoints(int n)

Set the number of point elements to n.

int mesh_t::getPoints()

Get the number of point elements.

void mesh_t::setEdges(int n)

Set the number of edge elements to n.

int mesh_t::getEdges()

Get the number of edge elements.

void mesh_t::setSurfaces(int n)

Set the number of surface elements to n.

int mesh_t::getSurfaces()

Get the number of surface elements.

void mesh_t::setElements(int n)

Set the number of volume elements to n.

int mesh_t::getElements()

Get the number of volume elements.

node_t* mesh_t::getNode(int n)

Get node n.

void mesh_t::setNodeArray(node_t* nodeArray)

Set node array point to nodeArray. Useful, if the user wants to take care of
memory allocation by him/her self.

void mesh_t::newNodeArray(int n)

Allocate memory for n nodes.

void mesh:t::deleteNodeArray()

Delete current node array.
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point_t* mesh_t::getPoint(int n)

Get point element n.

void mesh_t::setPointArray(point_t* pointArray)

Set point element array point to pointArray. Useful, if the user wants to take
care of memory allocation by him/her self.

void mesh_t::newPointArray(int n)

Allocate memory for n point elements.

void mesh_t::deletePointArray()

Delete current point element array.

edge_t* mesh_t::getEdge(int n)

Get edge element n.

void mesh_t::setEdgeArray(edge_t* edgeArray)

Set edge element array point to edgeArray. Useful, if the user wants to take
care of memory allocation by him/her self.

void mesh_t::newEdgeArray(int n)

Allocate memory for n edge elements.

void mesh_t::deleteEdgeArray()

Delete current edge elemet array.

surface_t* mesh_t::getSurface(int n)

Get surface element n.

void mesh_t::setSurfaceArray(surface_t* surfaceArray)

Set surface element array point to surfaceArray. Useful, if the user wants to
take care of memory allocation by him/her self.

void mesh_t::newSurfaceArray(int n);

Allocate memory for n surface elements.

void mesh_t::deleteSurfaceArray()
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Delete surface element array.

element_t* mesh_t::getElement(int n)

Get volume element n.

void mesh_t::setElementArray(element_t* elementArray)

Set volume element array point to elementArray. Useful, if the user wants
to take care of memory allocation by him/her self.

void mesh_t::newElementArray(int n)

Allocate memory for n volume elements.

void mesh_t::deleteElementArray()

Delete current volume element array.

F.3 node t

The class node t has been declared in src/meshtypes.h. It provides the
following public methods for accessing node data:

void node_t::setX(int n, double x)

Set component n of the position vector to x.

double node_t::getX(int n)

Get component n of the position vector.

void node_t::setXvec(double* v)

Set the position vector to v.

double* node_t::getXvec()

Get the position vector.

void node_t::setIndex(int n)

Set the index of the node to n.

int node_t::getIndex()

Get the index of the node.
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F.4 Base element class element t

The class element t provides the following methods for accessing element
data:

void element_t::setNature(int n)

Set element nature to n (either PDE UNKNOWN, PDE BOUNDARY, or
PDE BULK).

int element_t::getNature()

Get the element nature.

void element_t::setCode(int n)

Set element code to n (202 = two noded line, 303 = three noded triangle, ...)

int element_t::getCode()

Get the element code.

void element_t::setNodes(int n)

Set the number of nodes to n.

int element_t::getNodes()

Get the number of nodes.

void element_t::setIndex(int n)

Set element index to n.

int element_t::getIndex()

Get the element index.

void element_t::setSelected(int n)

Set the selection state (1=selected, 0=unselected).

int element_t::getSelected()

Returns 1 if element is selected. Otherwise returns 0.

int element_t::getNodeIndex(int n)

Get the index of node n.
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void element_t::setNodeIndex(int m, int n)

Set the index of node m to n.

int* element_t::getNodeIndexes()

Get the indexes of all nodes.

void element_t::newNodeIndexes(int n)

Allocate space for n node indexes.

void element_t::deleteNodeIndexes()

Delete all node indexes.

F.5 Point element class point t

The class point t inherits all public members from class element t. In addi-
tion to this, it provides the following methods for accessing and manipulating
point element data:

void setSharp(bool b);

Mark the point element “sharp” (b=true) or not (b=false).

bool isSharp();

Returns true if the point element is “sharp”. Otherwise returns false.

void setEdges(int n);

Set the number of edges elements connected to the point to n.

int getEdges();

Get the number of edge elements connected to the point.

void setEdgeIndex(int m, int n);

Set the index of m’th edge element to n.

int getEdgeIndex(int n);

Get the index of n’th connected edge element.

void newEdgeIndexes(int n);

Allocate space for n edge element indexes.

void deleteEdgeIndexes();

Delete all edge element indexes.
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F.6 Edge element class edge t

The class edge t inherits all public methods from element t. It also provides
the following methods for accessing and manipulating edge element data:

void edge_t::setSharp(bool b)

Mark the edge sharp (b=true) or not (b=false).

bool edge_t::isSharp()

Returns true if the edge is sharp.

void edge_t::setPoints(int n)

Set the number of point elements connected to the edge to n.

int edge_t::getPoints()

Get the number of point elements connected to the edge.

void edge_t::setPointIndex(int m, int n)

Set the index of point element m to n.

int edge_t::getPointIndex(int n)

Get the index of point element n.

void edge_t::newPointIndexes(int n)

Allocate space for n point element indexes.

void edge_t::deletePointIndexes()

Delete all point element indexes.

void edge_t::setSurfaces(int n)

Set the number of surface elements connected to the edge to n.

int edge_t::getSurfaces()

Get the number of surface elements connected to the edge.

void edge_t::setSurfaceIndex(int m, int n)

Set the index of surface element m to n.

int edge_t::getSurfaceIndex(int n)

Get the index of m’th surface element connected to the edge.

void edge_t::newSurfaceIndexes(int n)

Allocate space for n surface element indexes.

void edge_t::deleteSurfaceIndexes()

Delete all surface element indexes.
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F.7 Surface element class surface t

Finally, the class surface t provides the following public methods for access-
ing and manipulating surface element data, besides of those inherited from
the base element class element t:

void surface_t::setEdges(int n)

Set the number of edge elements connected to the surface to n.

int surface_t::getEdges()

Get the number of edge elements connected to the surface element.

void surface_t::setEdgeIndex(int m, int n)

Set the inde of m’th edge element to n.

int surface_t::getEdgeIndex(int n)

Get the index of n’th edge element connected to the surface element.

void surface_t::newEdgeIndexes(int n)

Allocate space for n edge element indexes.

void surface_t::deleteEdgeIndexes()

Delete all edge element indexes.

void surface_t::setElements(int n)

Set the number of volume elements connected to the surface element to n.

int surface_t::getElements()

Get the number of volume elements connected to the surface element.

void surface_t::setElementIndex(int m, int n)

Set the index of m’th volume element to n.

int surface_t::getElementIndex(int n)

Get the index of n’th volume element connected to the surface.

void surface_t::newElementIndexes(int n)

Allocate space for n volume element indexes.
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void surface_t::deleteElementIndexes()

Delete all volume element indexes.

void surface_t::setNormalVec(double* v)

Set the normal vector to the surface element.

double* surface_t::getNormalVec()

Get the normal vector for the surface element.

double surface_t::getNormal(int n)

Get component n of the normal vector.

void surface_t::setNormal(int n, double x)

Set component n of the normal to x.

void surface_t::setVertexNormalVec(int n, double* v)

Set the normal vector for vertex n to v.

void surface_t::addVertexNormalVec(int m, double* v)

Add vector v to the normal in vertex n.

void surface_t::subVertexNormalVec(int m, double* v)

Subtract vector v from the normal in vertex n.

double* surface_t::getVertexNormalVec(int n)

Get the normal vector in vertex n.
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